cow-word-search/shell.nix
2025-02-08 22:22:37 -06:00

32 lines
714 B
Nix

{
pkgs ? import <nixpkgs> { },
}:
pkgs.callPackage (
{
mkShell,
# rustc,
# cargo,
rustup,
rustPlatform,
rustfmt,
clippy,
rust-analyzer,
}:
mkShell {
strictDeps = true;
nativeBuildInputs = [
rustup
rustfmt
clippy
rust-analyzer
];
# Certain Rust tools won't work without this
# rust-analyzer from nixpkgs does not need this.
# This can also be fixed by using oxalica/rust-overlay and specifying the rust-src extension
# See https://discourse.nixos.org/t/rust-src-not-found-and-other-misadventures-of-developing-rust-on-nixos/11570/3?u=samuela. for more details.
RUST_SRC_PATH = "${rustPlatform.rustLibSrc}";
}
) { }