Chandler Swift
9e3c4ee13e
It looks like this was CLOSED WONTFIX: How can we _possibly_ know that upon an error, the developer might want us to send an indication of that error??!!1! Snark aside (mine and his): it looks like there's not a great way to enable sane error behavior globally :/ https://caddy.community/t/handling-errors-globally/17174/2 In the future, I should probably make this a snippet or something.
18 lines
374 B
Nix
18 lines
374 B
Nix
|
|
{
|
|
services.caddy.virtualHosts."files.chandlerswift.com".extraConfig = ''
|
|
encode zstd gzip
|
|
file_server
|
|
root * /srv/www/files.chandlerswift.com
|
|
|
|
handle_errors {
|
|
respond "{err.status_code} {err.status_text}"
|
|
}
|
|
'';
|
|
systemd.tmpfiles.settings."10-files-chandlerswift-com" = {
|
|
"/srv/www/files.chandlerswift.com" = {
|
|
d = {};
|
|
};
|
|
};
|
|
}
|