Chandler Swift
9e3c4ee13e
It looks like this was CLOSED WONTFIX: How can we _possibly_ know that upon an error, the developer might want us to send an indication of that error??!!1! Snark aside (mine and his): it looks like there's not a great way to enable sane error behavior globally :/ https://caddy.community/t/handling-errors-globally/17174/2 In the future, I should probably make this a snippet or something.
30 lines
850 B
Nix
30 lines
850 B
Nix
|
|
{
|
|
services.caddy.virtualHosts."home.chandlerswift.com".extraConfig = ''
|
|
encode zstd gzip
|
|
file_server
|
|
root * /srv/www/home.chandlerswift.com
|
|
reverse_proxy /grafana/* localhost:3000
|
|
# hide .git # ???
|
|
|
|
file_server /sheets/* {
|
|
browse ${./caddy-browse-template.html}
|
|
|
|
# TOOD: is there a better way to strip the prefix here? This shouldn't be
|
|
# vulnerable to a directory traversal attack (and it doesn't really
|
|
# matter anyway; everything in there is public somewhere or another!) but
|
|
# it sorta feels wrong to do this without a `/sheets` suffix.
|
|
root /mnt/bigbird-public
|
|
}
|
|
|
|
handle_errors {
|
|
respond "{err.status_code} {err.status_text}"
|
|
}
|
|
'';
|
|
systemd.tmpfiles.settings."10-home-chandlerswift-com" = {
|
|
"/srv/www/home.chandlerswift.com" = {
|
|
d = {};
|
|
};
|
|
};
|
|
}
|